ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • vm 에서 guest additions 가 버전이 낮다고 나올때
    Programmer/Vagrant 2013. 7. 19. 23:04

    vagrant 는 다양한 vm를 연동하여 사용가능하지만, 

    가장 많이 쓰이는 것은 virtualbox 일 것이다. 

    초기부터 지원했던 가상화 환경이기 때문에

    여튼 무료인 virutalbox의 경우 쓸만하지만 여러모로 불편한 점등이 있다. ( USB 등을 인식시킬때의 제약이라던지.. )

    암튼  VirtualBox Extension Pack 를 기본적으로 설치하게 되는데, 

    이때, vm등에게도 관련 패키지를 설치해야하는 경우가 있다. 

    그 이후에 VirtualBox를 업그레이드 하게 되면 그 전에 생성했던 vm을 vagrant up을 통해 구동 시킬때 다음과 같은 화면을 만나게 될것이다. 

    구동할때마다 저렇게 노란색의 워닝 비슷한 메시지를 보게 되면 영 찜찜하다.

    일단, 업데이트를 하려면 vagrant-vbguest라는 플러그인이 필요하다.

    먼저 이것부터 설치를 해준다.

    vagrant plugin install vagrant-vbguest

    그리고, 다음과 같이 Vagrantfile  에 설정 사항(굵은 라인)을 한줄 추가 시켜 준다. 

    Vagrant.configure("2") do |config|

      config.vm.network :private_network, ip: "192.168.2.10"

      config.vbguest.auto_update = true

    end

    일단, 이렇게 하면 알아서 자동으로 업데이트 해준다. 

    매번 업데이트하기가 싫다면, 콘솔에서 다음과 같이 실행해도 된다.

    댓글 0

Designed by Tistory.